Control Panel Outage
Incident Report for EveryCloud
Resolved
Control Panel should be fully restored and accessible.
Posted 7 months ago. Jan 10, 2018 - 17:12 GMT
Identified
We have identified an issue causing some customer to not be able to access the Control Panel. We are working on a resolution, now.
Posted 7 months ago. Jan 10, 2018 - 16:02 GMT