Control Panel Issue
Incident Report for EveryCloud
Resolved
Resolved: The Control Panel and releasing of emails from the spam digest reports are operational.
Posted 12 months ago. Nov 02, 2017 - 11:03 GMT
Investigating
Access to the Control Panel is currently unavailable. This is affecting the releasing of emails from the spam report. We are working on a fix.
Posted 12 months ago. Nov 02, 2017 - 09:42 GMT