Control panel issue
Incident Report for EveryCloud
Resolved
The control panel issues have been resolved and users/adminstrators are able to login.
Posted 10 months ago. Oct 18, 2017 - 15:06 BST
Update
Spam reports - issues resolved with spam digest reports.
Posted 10 months ago. Oct 18, 2017 - 14:42 BST
Update
Spam reports - end users are currently unable to release emails from their spam digest reports.
Posted 10 months ago. Oct 18, 2017 - 14:40 BST
Investigating
8.55am Eastern / 1.55pm UK - We are currently experiencing an issue with the control panel that is preventing users logging in.
Posted 10 months ago. Oct 18, 2017 - 13:55 BST