Spam Report - Whitelist Release
Incident Report for EveryCloud
Resolved
Issue releasing emails via the spam report using the Whitelist option should now be resolved.
Posted 10 months ago. Jul 04, 2018 - 20:05 BST
Identified
We are working to correct an issue that is not allowing some of our customers to whitelist releases from the spam report.
Posted 10 months ago. Jul 03, 2018 - 20:43 BST
This incident affected: Blacklisting.