Partial Service Disruption to POP3 service
Incident Report for EveryCloud
Resolved
The issue regarding the Partial Service Disruption to:

Components: Email Continuity, IMAP/POP3 Services has now been resolved.
Posted 2 months ago. Oct 11, 2018 - 14:19 BST
Investigating
Incident Status: Partial Service Disruption

Components: Email Continuity, IMAP/POP3 Services
Changes to POP3/IMAP accounts or new POP3/IMAP accounts are not deployed on the live system. This also affects Continuity Service users. We are working on a solution.
Posted 2 months ago. Oct 11, 2018 - 12:00 BST
This incident affected: Hosted Email - POP3 / IMAP Mailboxes.