POP3/IMAP outage
Incident Report for EveryCloud
Resolved
All POP3/IMAP and web based mailbox services are now fully functional again. Please accept our most sincere apologies for the inconvenience caused to both you and your users.
Posted about 1 month ago. Oct 08, 2018 - 15:51 BST
Update
We are continuing to investigate this issue.
Posted about 1 month ago. Oct 08, 2018 - 15:49 BST
Update
The Continuity Service is also affected.

Whilst it is now partially possible to retrieve and send again via the mentioned services. We are working on a solution.
Posted about 1 month ago. Oct 08, 2018 - 10:37 BST
Investigating
Partial Service Disruption
Components
IMAP/POP3 Services, Websafe

It is not possible to retrieve mails via POP3/IMAP at the moment. We are working hard on resolving this as a matter of extreme urgency.
Posted about 1 month ago. Oct 08, 2018 - 09:50 BST
This incident affected: Hosted Email - POP3 / IMAP Mailboxes and Email Continuity.