Support Hotline Unavailable
Incident Report for EveryCloud
Resolved
This incident has been resolved.
Posted Jan 08, 2020 - 23:11 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 08, 2020 - 17:21 GMT
Identified
There has been an outage at one of our data centers, and we are currently unable top take any calls.

We will update you as soon as possible.
Posted Jan 08, 2020 - 13:41 GMT
This incident affected: Support Portal.