Under urgent maintenance
Incident Report for EveryCloud
Resolved
This incident has been resolved.
Posted 8 months ago. Mar 14, 2018 - 20:23 GMT
Update
Just to clarify, this only affects our free mail flow monitor.
Posted 8 months ago. Mar 14, 2018 - 15:37 GMT
Investigating
We are experiencing some issues with our mail delivery, so currently, the system is down. Sorry for the inconvenience.
Posted 8 months ago. Mar 14, 2018 - 15:35 GMT