Office 365 US Smarthost Certificate Issues
Incident Report for EveryCloud
Resolved
Office 365 Outbound sending should now be resolved. If you are a US customer using Office 365 you may switch back to outbound.us.everycloudtech.com
Posted 10 months ago. May 03, 2018 - 04:46 BST
Monitoring
We are working to resolve and issue with a Certificate in our US Data Center. If you are using Office 365 and using the outbound.us.everycloudtech.com smarthost it is recommended that you use outbound.everycloudtech.us until the issue is resloved.
Posted 10 months ago. May 02, 2018 - 21:28 BST
This incident affected: Email Delivery - Outbound.