Control Panel update performed 21.6.18
Incident Report for EveryCloud
Resolved
This incident has been marked closed
Posted 5 months ago. Jun 25, 2018 - 07:58 BST
Investigating
Due to a planned Control Panel update performed last night 21.6.18-22.6.18. The Control Panel MANGEMENT>USER tab. Has now been changed to display the word POSTBOXES.
Posted 5 months ago. Jun 22, 2018 - 12:05 BST
This incident affected: Control Panel.