Hosted Mail Solution Outage
Incident Report for EveryCloud
Resolved
Hosted POP/IMAP and Continuity should be restored. Please try to re-log in and access your email.
Posted about 1 month ago. Oct 19, 2018 - 22:38 BST
Investigating
POP3/IMAP Login is not possible at the moment. Emails can therefore not be retrieved
Posted about 1 month ago. Oct 19, 2018 - 18:54 BST
This incident affected: Hosted Email - POP3 / IMAP Mailboxes and Email Continuity.