Delay with US MX Servers
Incident Report for EveryCloud
Resolved
This incident has been resolved.
Posted 11 months ago. Aug 10, 2018 - 07:55 BST
Update
We are continuing to work on a fix for this issue.
Posted 11 months ago. Aug 10, 2018 - 07:54 BST
Identified
We have identified an issue that may cause some customers using the US Data Center to see delays in receiving or sending emails We are working to resolve it.
Posted 11 months ago. Aug 10, 2018 - 07:04 BST
This incident affected: Email Delivery - Inbound and Email Delivery - Outbound.