Primary Data Center Performance Issues
Incident Report for EveryCloud
Resolved
This incident has been resolved.
Posted about 2 months ago. Oct 20, 2018 - 00:56 BST
Monitoring
For the moment, the service is operational again. There will be a maintenance continuing from the 17th Oct onwards to next week to deal with the performance issue furtheron.
The maintenance will not harm the services.

We will keep you posted if a service is not fully operational on this site. You will find a new maintenance shortly after this message that will give keep you posted on the upcoming process.
Posted about 2 months ago. Oct 19, 2018 - 17:52 BST
Identified
Processing at the Primary Data Center is delayed. The mail traffic arrives delayed, but is functional. We are still working on a solution.
Posted about 2 months ago. Oct 19, 2018 - 17:39 BST
This incident affected: Email Delivery - Inbound, Email Delivery - Outbound, Control Panel, Hosted Email - POP3 / IMAP Mailboxes, Spam Reports, Email Continuity, and Email Archiving.