Primary UK Telephone Line Busy
Incident Report for EveryCloud
Resolved
Our Primary Line is fully operational again.

But please remember you can always use the free phone number to contact us. 08000 246906
Posted about 2 months ago. Oct 26, 2018 - 08:07 BST
Identified
There is a major Outage with our Telephony Vendor for our Primary UK Line 02030 869 833 which is presenting as permanently Busy.

Please Use out New Toll Free Number 08000 246906 to contact EveryCloud this is fully operational.
Posted about 2 months ago. Oct 25, 2018 - 11:52 BST